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Introduction  
Google Docs is a web-based word processing program included in the productivity tool suite 

from Google Drive. Using this tool, users can create, edit, and share documents online, in real-

time and without needing to download additional software. This white paper presents the 

findings of a cognitive usability test performed on twenty Google Docs tasks. A typical user of 

this word processor may have the foundational knowledge of writing papers, resumes, or other 

projects. However, users typically go to Google Docs for added features the program offers, such 

as sharing documents, adding comments, and editing images. To test these and additional Google 

Docs features, I assumed the role of a new student studying Latin and who was in the process of 

writing a paper for a Latin language class.  

Methodology  

Environment 

The cognitive usability test was performed on March 24th, 2023 in my dorm room on a personal 

Windows laptop. A personal Gmail account was used to log in and access Google Docs.  A 

second Google tab was opened in Google Chrome to translate English to Latin for the contents of 

the paper.  

 

Tasks  

I performed the following twenty tasks to write a paper for my hypothetical foreign language 

class, written in Latin and meant to describe the history of the language.  

 

       0.   Write the contents of the paper using Google Translate and paste into a Google Doc 

1. Clear formatting on copy and pasted text  

2. Add a font that looks like the author’s physical handwriting  

3. Add a table of contents in the side bar  

4. Add a header different from the first page and page numbers  

5. Search for a relevant image to insert  

6. Edit the inserted image 

7. Use the explore tool to learn more about a word 

8. Indent the resources/works cited section  

9. Insert a footnote  

10. Find and replace incorrect or desired text 

11. Use the voice typing feature to write faster  

12. Create a nonstandard text substitution  

13. Use the dictionary tool  

14. Edit foreign language text with language accents  

15. Revise your edits  

16. Sign the document  

17. Date the document  

18. Share the document  

19. Insert, reply, resolve, and read comments  

20. Translate the document back to English  



Kay Atkinson                                                                                                                                              
P a g e  | 4 

   

 

Metrics and Evaluating Criteria 

Each task was evaluated using five metrics and the five-point Likert scale. Firstly, the following 

five questions were asked regarding their respective metric:  

 

Effective:                       Was the task able to be completed using the features of Google Docs?   

 

Efficient:  Was the task completed within a reasonable amount of time using Google 

Docs features?  

 

Engaging:  Did Google Docs have a style and appearance that was helpful to perform 

this task? 

 

Error Tolerant:  Were there few times when your attempts to do this task in Google Docs 

failed? And if there were, was there a recovery method?  

 

Easy to Learn:  Was it easy to learn this task in Google Docs?  

 

The five-point Likert scale was used to answer these five metric questions with one of the 

following: strongly disagree, somewhat disagree, neutral, somewhat agree, and strongly 

agree. Table 1 below gives an example using Task 1. To quantify the qualitative results, a score 

of 25 meant the task was rated perfect on cognitive usability while anything less than 25 meant 

the task’s usability had room for improvement. The “Additional Notes” section on the table 

allows for elaboration on why a 5 out of 5 score was not attained per a given task.   

 
Task 1 Clear formatting on copy and pasted text  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 
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Table 1. Example 

of Likert Scale 

Results for Task 

1 

Results  

Task 1: Clear Formatting on Copy and Pasted Text  

 
Figure 1. Task 1 

The first task involved copying and pasting a poem written in Latin into the Google Docs paper. 

The poem was copied from a website and when pasted to the Google Doc, it held a different 

format of a gray highlight and different font. To reformat this text, I went to “Format -> Clear 

formatting”. If the user had previous knowledge of what functions were offered under the 

“Format” tab, then this would be a very easy task. However, without previous knowledge about 

the tab, then this task renders itself harder to complete, thus a less than perfect score of 22.  

 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

Overall, an easy task to learn and perform. The only drawback 

is that you must know to go from “Format -> Clear 

formatting” while having all desired text is highlighted.  

 

Total = 22 
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Task 2: Add a Font that Looks Like the Author’s Handwriting  

 
Figure 2. Task 2  

The second task was to liven up the look of the “Lingua Latin” paper with a new font that 

resembled the handwriting of the author. However, a glance at the available fonts in Google 

Docs gives no result for a realistic handwritten font. The user may add a new font, however, with 

the “Add Font” feature. To do this, the user would click on the down arrow next to the font 

selection, then go to “Add fonts” at the top of the drop down. From Figure 2, we can choose 

between three filters. Using the filters requires trial and error as to what each does. Because of 

this, the task is not easy to learn how to do and renders a score of 19.  

 

Task 3: Add a Table of Contents in the Side Bar  

 
Figure 3. Task 3  

This feature of Google Docs is incredibly helpful, but the user must know where to look to go to 

the “Table of Contents” side bar. This is done by clicking on three horizontal bars in the lefthand 

corner beneath the tool bar. Though somewhat hard to access, adding headers to the table of 

contents is straightforward. The user may select their desired text, go to “Normal text -> Heading 

1/Heading 2/Heading 3” and, once clicked, text is automatically added to the table of contents. 
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Clicking on a heading in the “Table of Contents” bar will make the screen jump to that section in 

the Google Doc. Again, because of hard maneuverability the score for this task is 19.  

 

Task 4: Add a Header Different from the First Page and Page Numbers  

 
Figure 4. Task 4  

To insert a header, the user must go to “Insert -> Header or Footer” and click on “Header”. From 

there, it is easy to right-align a name and then left-align for page numbers. Unfortunately, page 

numbers are not straightforward to insert. The user must highlight text or place their cursor 

where they would like to insert a page number, then go to “Options” and from the drop down 

select “Page numbers”. The page number will appear subsequently on all pages. To keep the 

header different from all other pages in the documents, user can easily click “Different first 

page”. Because of the page numbers, this task has a score of 18.  

 

Task 5: Search for a Relevant Image to Insert  

 
Figure 5. Task 5  

Overall, one of the most useful and easy tasks to perform is inserting an image in Google Docs. 

This can be done by going to “Insert -> Image -> Search the web/Upload from computer” or 
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other places. However, the search tool in Google Docs gives immediate and creative results. 

Make your search in the search bar on the right and then click “Insert” to place your image where 

your mouse cursor is on the page. Most users should find they are comfortable with this feature if 

they have ever sent images via text message or email. Overall, this gives a perfect score of 25.  

 

Task 6: Edit the Inserted Image  

 
Figure 6. Task 6 

To edit an image, either a right click on the image or by selecting “Image Options” in the top 

toolbar, a user is automatically given a right-sided toolbar with additional editing options. From 

this toolbar, a user can edit the size, position, color, contract, and brightness. By simply clicking 

on the image, the user can also choose different text wrapping options. Intuitive and simple, this 

task receives a score of 25.  

 

Task 7: Use the Explore Tool to Learn More About a Word 

 
Figure 7. Task 7  

If a user is a curious about the origins, definition, or other aspects of a word in a Google Docs, 

they can highlight the word and go to “Tools -> Explore”. From there, they are able to see what 
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the Internet has to offer about the specific word. Here, the user only needs to know to go to 

“Tools” to find the “Explore” option. However, there are times when Google searches for a 

word, but the word may be unknown or give ambiguous results. Because of this, the task scores a 

22.  

 

Task 8: Indent the Resources/Works Cited Section  

 
Figure 8. Task 8  

In many cases, a Resources or Works Cited section will be formatted with a hanging indent. A 

user can select their Resources section and then do the following to get to the hanging indent 

option for text formatting: “Format -> Align & indent -> Indentation options”. Once in 

“Indentation options” the user can click on the dropdown box and select “Hanging”, as well as 

choose the size of the indent. These maneuvers are confusing, however, for a user that does not 

know what options are available in the “Indentation options” tab. Therefore, this feature of 

Google Docs makes the user spend more time learning where to find the “Hanging” option than 

is desired. This task’s score is 17.   

 

Task 9: Insert a Footnote  

 
Figure 9. Task 9  
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Going to “Insert -> Footnote” will insert a footnote at the bottom of the page a user in on 

currently. The superscript starting the footnote is added automatically. What is not added 

automatically is the superscript within the body of the text. To make a footnote work, the number 

inside it corresponds to a word inside the body (in this case the Conclusion) of the paper. If the 

user does not know how to insert a superscript on a word, then the footnote has no word it 

defines. Inserting a superscript can be done by going to “Format -> Text -> Superscript”, which 

is an added step to this task and increases complexity for the user. This gives the task a score of 

15.  

 

Task 10: Find and Replace Incorrect or Desired Text 

 
Figure 10. Task 10  

If the user desires to replace a word or phrase in their paper, they may do so by going to “Edit -> 

Find and replace”. Two simple steps will give the screen as shown in Figure 10. This style and 

appearance allow users to learn quickly about finding and replacing desired text within their 

document. Additionally, this feature can be found beneath the “Edit” tab, which is intuitive for 

users. This receives a perfect score of 25.  

 

Task 11: Use Voice Typing Feature to Write Faster  

 
Figure 11. Task 11  

When the user is short on time or is tired of typing, they may go to “Tools -> Voice Typing” and 

speak their words to life inside Google Docs. The speaker icon can simply be pressed to start a 

recording and pressed again to finish a recording. The dropdown button above the icon can be 
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used to choose which language you will be speaking in. Again, another perfectly scored and 

usable task.  

 

Task 12: Create a Nonstandard Text Substitution  

 
Figure 12. Task 12  

Many users will want to be creative in their documents, and allowing users to add substitutions 

for certain characters or words is another feature of Google Docs. However, getting to the tool to 

do this is rather complicated and is not a known feature for users. To create or edit text 

substitutions, a user must go to “Tools -> Preferences -> Substitutions ->” then click on the 

substitution they would like to edit or click an empty box to add one. Logically, I thought I could 

find this option under “File” or “Edit”, but because “Tools” is not the immediate go-to, this is a 

harder to learn task. This gives the task a score of 16.  

 

Task 13: Use the Dictionary Tool  

 
Figure 13. Task 13   

Here, writing in a foreign language may mean the user needs help to understand a certain word’s 

definition. Fortunately, the dictionary tool under “Tools” is simple to use and gives a definition 

from the web. This works the same way as a Google search – if not easier. This task is scored 

perfectly.   

 

 

 



Kay Atkinson                                                                                                                                              
P a g e  | 12 

   

 

Task 14: Edit Foreign Language Text with Language Accents  

 
Figure 14. Task 14  

Here is another example of needing a Google Docs feature when writing in a foreign language. 

To insert accents onto consonants or vowels, a user must go to “Insert -> Special characters” and 

then select their desired language from the dropdown on the top left. Though a somewhat more 

complicated process to complete, the functionality and versatility of the tool makes for 

exceptional user experience and effectiveness. Meaning this task scores a 21.  

 

Task 15: Revise Your Edits 

 
Figure 15. Task 15  

As the user nears the end of writing their paper, they will need to make edits. Or, if they want to 

revert to a previous version of their work, going to “File -> Version history” can show them their 

previously saved versions. While this feature is nice and easy to use, only some of the previous 

changes to the document will be saved as options to revert to. This scores the task as a 20.  
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Task 16: Sign the Document  

 
Figure 16. Task 16 

Unfortunately, there is no explicit option for signing Google Docs. Instead, the user must know 

about the drawing option located in “Insert -> Drawing -> New -> Drawing”. This is hard to 

learn for users and has flawed execution because the mouse makes for a clunky signature. To 

sign the document when nearing its completion is a crucial task, but Google Docs lacks this 

ability for users uninclined to drawing with the mouse. Because of this, this task is scored an 11.  
 

Task 17: Date the Document  

 
Figure 17. Task 17 

To insert an important date into a Google Docs, a user can go to “Insert -> Smart clips -> Date” 

for the date feature. A new user may have a hard time discovering what the “Smart clips” option 
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has beneath it, but once learned, this feature works for many different dates and can be used 

easily in the header.  For this reason, this task is scored a 22.  

Task 18: Share the Document 

  
Figure 18. Task 18 

Though an incredibly useful and helpful feature for sharing documents for either collaboration or 

proof reading, Google Docs sharing feature has a minor user flaw. Figure 18 depicts the sharing 

option for the “Lingua Latin” document. However, in order to share the document, you must 

have the other person’s email. If not that, you may have to use a “Public” option which allows 

anyone to access your document. The user’s desires to share their file a certain way may not be 

met with these features. Additionally, the sharing options may be hard to learn at first. This task 

has a score of 16.  

 

Task 19: Insert, Reply, Resolve, and Read Comments  

 
Figure 19. Task 19  

Critical in receiving edits and making revisions are comments. Google Docs has a user-friendly 

and versatile tool for this. In Figure 19, a user reads comment on the poem from another user 
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(possibly editor). The comment may be resolved with the blue check mark, replied to with the 

three dots, or deleted. All can be done without clicking options from the topmost toolbar. This 

scores a perfect score.  

 

Task 20: Translate the Document Back to English  

 
Figure 20. Task 20  

At the end of the user’s project, they wish to translate their paper to English. This can be easily 

done by going to “Tools -> Translate document”. The user will be prompted as in Figure 20 and 

can save the translated document as a copy to their Google Drive. This preserves the original in a 

process easy for the user to comprehend and use. This final task receives a score of 25.  

 

Conclusion 
In conclusion, we performed a cognitive usability test with a Google Docs-user, a student, who 

needed to write a paper in Latin using twenty features offered by Google Docs. I then ranked 

these features according to the five metrics of efficiency, effectiveness, engagement, error 

tolerance, and ease of learning. I found them to have an average rank of 20.65 on the Likert 

scale. Using the cognitive usability test and this average, a statement may be made about Google 

Docs having a good user-centered design. Figure 21 shows evidence that most tasks were 

completed with mid-range to high-range scaling. In the end, the student was successful in 

developing their final paper using Google Docs. 
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Figure 21. Evaluation of 20 Tasks Using the Five Metrics and Likert Scale  

Recommendations  
For a novice Google Docs-user, some tools and tasks offered may not be easy to find. This was 

the case in inserting a signature, setting up text substitution, and adding fonts. In fact, in the case 

of signing a document, Google Docs offers no signature tool and instead relies on their Draw 

feature. While this works, the Draw feature is not easy to use for beginning users and may not be 

apparent to even intermediate users. Additionally, the sharing capabilities of Google Docs would 

be greatly enhanced if verification codes via other email or phone number could be sent when a 

document is publicly shared. This way, only those with the code can access the document. This 

would be particularly useful when only the phone number and not the Gmail of the other user is 

known.  

Bibliography  
Google – retrieved from https://google.com/docs/ 

Appendix 
 

Tasks Google Docs 

Task 1 Clear formatting on copy and pasted text  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
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 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

Overall, an easy task to learn and perform. The only drawback 

is that you must know to go from Format -> Clear formatting 

while having all desired text highlighted.  

 

 

Total = 22 

 

Tasks Google Docs 

Task 2 Add a font that looks like the author’s handwriting  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

There are more steps to this task than in others, making the 

learning curve difficult. And to get more fonts, a user would 

have to explore with the three filters.  

 

 

Total = 19  

Tasks Google Docs 

Task 3 Add a table of contents in the side bar  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

The table of contents is hard to find if the user does not know 

where to look for it (lefthand top corner). A major asset once 

created.  

 

 

Total = 19 

 

Tasks Google Docs 

Task 4 Add a header different from the first page and page numbers   

Efficient Was the task able to be completed using the features 
of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

May be difficult to use initially and prone to have the cursor 

jumping around when inserting header. May accidentally enter 

a page number where you don’t want.  

 

 
Total = 18  

 

Tasks Google Docs 

Task 5 Search for a relevant image to insert  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

A very useful tool and able to be completely quickly and 

easily with Google Docs.   

 

 
Total = 25  

 

Tasks Google Docs 

Task 6 Edit the inserted image  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

User-friendly and easy to accomplish task.  

 

 

Total = 25  
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Tasks Google Docs 

Task 7 Use the explore tool to learn more about a word  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

User-friendly and easy to accomplish task.  

 

 

Total = 22 

 

Tasks Google Docs 

Task 8 Indent the resources/works cited section  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

Though effective upon completion, learning this task is hard 

and can be timely to perform.  

 

Total = 17 
 

Tasks Google Docs 

Task 9 Insert a Footnote   

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

To fully complete adding a footnote, a user must also know 

how to superscript the footnoted word in the body of the 

paper.  

 

Total = 15 

 

Tasks Google Docs 

Task 10 Find and replace incorrect or desired text  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

This task requires little learning and works for multiple 

scenarios of finding and replacing text.  

 

Total = 25  

 

Tasks Google Docs 

Task 11 Use voice typing feature to write faster  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

Multiple functionality and purposes exist for this easy-to-use 

and easy-to-learn tool.  

 

Total = 25  

 

Tasks Google Docs 

Task 12 Create a nonstandard text substitution  

Efficient Was the task able to be completed using the features 
of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

This option does not exist under a tab that would be thought of 

as logical. It’s placement in Tools is obscure and not user 

friendly.  

 

Total = 16 
 

Tasks Google Docs 

Task 13 Use the dictionary tool  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

Another useful Google Docs tool that will be used by a user at 

some point and requires few steps to complete.   

 

Total = 25  
 

Tasks Google Docs 

Task 14 Edit foreign language text with language accents 

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

This tool has additional functionality, despite it being 

somewhat hard to learn.  

 

Total = 21  
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Tasks Google Docs 

Task 15 Revise your edits  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

The tool is fairly simple to learn, but previous versions may 

not be the ones the software saved.  

 

Total = 20 

 

Tasks Google Docs 

Task 16 Sign the document  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

 User must use the Draw tool to insert a signature, there is no 

easy or explicit tool for signature insertion in Google Docs.  

 

Total = 11 
 

Tasks Google Docs 

Task 17 Date the document  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

To insert a date, you must know that the “Smart clips” option 

holds the date feature. Otherwise, useful and excellent tool.  

 

Total = 22 

 

Tasks Google Docs 

Task 18 Share the document  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

Initially challenging to learn how to share documents 

according to owner’s wishes and even then, a particular 

sharing option may be limited.  

 

Total = 16 

 

Tasks Google Docs 

Task 19 Insert, reply, resolve, and read comments  

Efficient Was the task able to be completed using the features 

of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

Comments are easily visible and the three dot option in the 

corner allows for easy edits and deletion. 

 

Total = 25  

 

Tasks Google Docs 

Task 20 Translate the document back to English  

Efficient Was the task able to be completed using the features 
of Google Docs?   

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Effective Was the task completed within a reasonable amount of 

time using Google Docs features?  
 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Engaging Did Google Docs have a style and appearance that was helpful 

to perform this task?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Error 

Tolerant 
Were there few times when your attempts to do this task 

in Google Docs failed? And if there were, was there a 

recovery method? 

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Easy to Learn Was it easy to learn this task in Google Docs?  

 Strongly 

Disagree 

Somewhat 

Disagree 

Neutral Somewhat 

Agree 

Strongly 

Agree 

1 2 3 4 5 
 

Additional 

Notes 

The translate option allows a copy of the original and the 

translation to be saved to the Google Drive. Few steps and 

easy to learn.  

 

Total = 25 
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